207-magic-update-zip.dpatch 791 B

12345678910111213141516171819
  1. #!/bin/sh /usr/share/dpatch/dpatch-run
  2. ## 207-magic-update-zip.dpatch
  3. ##
  4. ## DP: Update zip magic.
  5. @DPATCH@
  6. diff -Naurp file.orig/magic/Magdir/msdos file/magic/Magdir/msdos
  7. --- file.orig/magic/Magdir/msdos 2008-05-31 22:17:03.000000000 +0200
  8. +++ file/magic/Magdir/msdos 2008-06-13 09:44:56.000000000 +0200
  9. @@ -256,7 +256,7 @@
  10. # a few unknown ZIP sfxes, no idea if they are needed or if they are
  11. # already captured by the generic patterns above
  12. ->122 string Windows\ self-extracting\ ZIP \b, ZIP self-extracting archive
  13. +>0x7a string Windows\ self-extracting\ ZIP \b, ZIP self-extracting archive
  14. >(8.s*16) search/0x20 PKSFX \b, ZIP self-extracting archive (PKZIP)
  15. # TODO: how to add this? >FileSize-34 string Windows\ Self-Installing\ Executable \b, ZIP self-extracting archive
  16. #