1234567891011121314151617181920212223 |
- #!/bin/sh /usr/share/dpatch/dpatch-run
- ## 209-magic-update-os2.dpatch
- ##
- ## DP: Update OS/2 REXX magic.
- @DPATCH@
- diff -Naurp file.orig/magic/Magdir/msdos file/magic/Magdir/msdos
- --- file.orig/magic/Magdir/msdos 2008-06-13 09:44:56.000000000 +0200
- +++ file/magic/Magdir/msdos 2008-06-13 09:51:35.000000000 +0200
- @@ -14,8 +14,10 @@
-
- # OS/2 batch files are REXX. the second regex is a bit generic, oh well
- # the matched commands seem to be common in REXX and uncommon elsewhere
- -100 regex/c =^[\ \t]{0,10}call[\ \t]{1,10}rxfunc OS/2 REXX batch file text
- -100 regex/c =^[\ \t]{0,10}say\ ['"] OS/2 REXX batch file text
- +100 search/0xffff rxfuncadd
- +>100 regex/c =^[\ \t]{0,10}call[\ \t]{1,10}rxfunc OS/2 REXX batch file text
- +100 search/0xffff say
- +>100 regex/c =^[\ \t]{0,10}say\ ['"] OS/2 REXX batch file text
-
- 0 leshort 0x14c MS Windows COFF Intel 80386 object file
- #>4 ledate x stamp %s
|