211-magic-update-mono.dpatch 1007 B

123456789101112131415161718192021222324252627
  1. #!/bin/sh /usr/share/dpatch/dpatch-run
  2. ## 211-magic-update-mono.dpatch
  3. ##
  4. ## DP: Update Mono magic.
  5. @DPATCH@
  6. diff -Naurp file.orig/magic/Magdir/msdos file/magic/Magdir/msdos
  7. --- file.orig/magic/Magdir/msdos 2008-06-13 15:23:32.000000000 +0200
  8. +++ file/magic/Magdir/msdos 2008-06-13 15:28:28.000000000 +0200
  9. @@ -65,6 +65,7 @@
  10. >>&0 leshort 0x290 PA-RISC
  11. >>&18 leshort&0x0100 >0 32-bit
  12. >>&18 leshort&0x1000 >0 system file
  13. +>>&228 lelong >0 \b, Mono/.Net assembly
  14. >>&0xf4 search/0x140 \x0\x40\x1\x0
  15. >>>(&0.l+(4)) string MSCF \b, WinHKI CAB self-extracting archive
  16. >30 string Copyright\ 1989-1990\ PKWARE\ Inc. Self-extracting PKZIP archive
  17. @@ -94,7 +95,7 @@
  18. >>>>(0x3c.l+4) leshort 0x290 PA-RISC
  19. >>>>(0x3c.l+22) leshort&0x0100 >0 32-bit
  20. >>>>(0x3c.l+22) leshort&0x1000 >0 system file
  21. ->>>>(0x3c.l+232) lelong >0 Mono/.Net assembly
  22. +>>>>(0x3c.l+232) lelong >0 \b, Mono/.Net assembly
  23. >>>>(0x3c.l+0xf8) string UPX0 \b, UPX compressed
  24. >>>>(0x3c.l+0xf8) search/0x140 PEC2 \b, PECompact2 compressed