212-magic-update-pfm.dpatch 766 B

123456789101112131415161718192021222324
  1. #!/bin/sh /usr/share/dpatch/dpatch-run
  2. ## 212-magic-update-pfm.dpatch
  3. ##
  4. ## DP: Update pfm magic.
  5. @DPATCH@
  6. diff -Naurp file.orig/magic/Magdir/msdos file/magic/Magdir/msdos
  7. --- file.orig/magic/Magdir/msdos 2008-06-13 15:28:28.000000000 +0200
  8. +++ file/magic/Magdir/msdos 2008-06-13 15:32:04.000000000 +0200
  9. @@ -504,6 +504,13 @@
  10. # Acroread or something files wrongly identified as G3 .pfm
  11. # these have the form \000 \001 any? \002 \000 \000
  12. # or \000 \001 any? \022 \000 \000
  13. +0 belong&0xffff00ff 0x00010012 PFM data
  14. +>4 string \000\000
  15. +>6 string >\060 - %s
  16. +
  17. +0 belong&0xffff00ff 0x00010002 PFM data
  18. +>4 string \000\000
  19. +>6 string >\060 - %s
  20. #0 string \000\001 pfm?
  21. #>3 string \022\000\000Copyright\ yes
  22. #>3 string \002\000\000Copyright\ yes