1733423740.FILE5_46-7-gb3384a1f.pr-579-net147-fix-stack-overrun.patch 544 B

1234567891011121314151617
  1. Subject: PR/579: net147: Fix stack overrun.
  2. Origin: upstream, commit FILE5_46-7-gb3384a1f <https://github.com/file/file/commit/FILE5_46-7-gb3384a1f>
  3. Author: Christos Zoulas <christos@zoulas.com>
  4. Date: Thu Dec 5 18:35:40 2024 +0000
  5. Bug-Debian: https://bugs.debian.org/1101470
  6. --- a/src/readelf.c
  7. +++ b/src/readelf.c
  8. @@ -1726,7 +1726,7 @@
  9. Elf64_Phdr ph64;
  10. const char *linking_style;
  11. unsigned char nbuf[NBUFSIZE];
  12. - char interp[128];
  13. + char interp[NBUFSIZE];
  14. ssize_t bufsize;
  15. size_t offset, align, need = 0;
  16. int pie = 0, dynamic = 0;