rules 842 B

123456789101112131415161718192021222324252627282930
  1. #!/usr/bin/make -f
  2. # -*- makefile -*-
  3. # Sample debian/rules that uses debhelper.
  4. # This file was originally written by Joey Hess and Craig Small.
  5. # As a special exception, when this file is copied by dh-make into a
  6. # dh-make output file, you may use that output file without restriction.
  7. # This special exception was added by Craig Small in version 0.37 of dh-make.
  8. # Uncomment this to turn on verbose mode.
  9. #export DH_VERBOSE=1
  10. DPKG_EXPORT_BUILDFLAGS = 1
  11. include /usr/share/dpkg/buildflags.mk
  12. DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
  13. %:
  14. dh $@
  15. override_dh_auto_build:
  16. make package
  17. make library
  18. override_dh_makeshlibs:
  19. dh_makeshlibs -V 'libhttp-parser2.1 (>=2.1)'
  20. override_dh_strip:
  21. dh_strip --dbg-package=libhttp-parser2.1-dbg
  22. .PHONY: override_dh_strip override_dh_makeshlibs override_dh_auto_build