debian.improve-installation.patch 830 B

12345678910111213141516171819202122232425262728293031
  1. Description: Improve installation
  2. Author: Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
  3. Forwarded: not-needed
  4. Last-Update: 2020-02-24
  5. * Make LIBDIR overridable from debian/rules
  6. * Install the .a file
  7. --- a/Makefile
  8. +++ b/Makefile
  9. @@ -62,7 +62,7 @@
  10. INSTALL ?= install
  11. PREFIX ?= /usr/local
  12. -LIBDIR = $(PREFIX)/lib
  13. +LIBDIR ?= $(PREFIX)/lib
  14. INCLUDEDIR = $(PREFIX)/include
  15. ifeq (darwin,$(PLATFORM))
  16. @@ -130,9 +130,10 @@
  17. tags: http_parser.c http_parser.h test.c
  18. ctags $^
  19. -install: library
  20. +install:
  21. $(INSTALL) -D http_parser.h $(DESTDIR)$(INCLUDEDIR)/http_parser.h
  22. $(INSTALL) -D $(LIBNAME) $(DESTDIR)$(LIBDIR)/$(LIBNAME)
  23. + $(INSTALL) -D libhttp_parser.a $(DESTDIR)$(LIBDIR)/libhttp_parser.a
  24. ln -sf $(LIBNAME) $(DESTDIR)$(LIBDIR)/$(SONAME)
  25. ln -sf $(LIBNAME) $(DESTDIR)$(LIBDIR)/$(SOLIBNAME).$(SOEXT)