use-ldflags.patch 415 B

123456789101112131415
  1. Description: Use hardened LDFLAGS
  2. Add "read-only relocation" link flag when building library
  3. Author: Praveen Arimbrathodiyil <praveen@debian.org>
  4. Last-Update: 2013-06-13
  5. --- a/Makefile
  6. +++ b/Makefile
  7. @@ -36,6 +36,7 @@
  8. CFLAGS_LIB = $(CFLAGS_FAST) -fPIC
  9. LDFLAGS_LIB = -shared
  10. +LDFLAGS_LIB += $(LDFLAGS)
  11. ifneq (darwin,$(PLATFORM))
  12. # TODO(bnoordhuis) The native SunOS linker expects -h rather than -soname...