1234567891011121314151617181920212223242526272829303132 |
- Description: Improve installation
- Author: Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
- Forwarded: not-needed
- Last-Update: 2018-04-07
- * Make LIBDIR overridable from debian/rules
- * Install the .a file
- * Don't rebuild library in install target
- --- a/Makefile
- +++ b/Makefile
- @@ -62,7 +62,7 @@
-
- INSTALL ?= install
- PREFIX ?= /usr/local
- -LIBDIR = $(PREFIX)/lib
- +LIBDIR ?= $(PREFIX)/lib
- INCLUDEDIR = $(PREFIX)/include
-
- ifeq (darwin,$(PLATFORM))
- @@ -130,9 +130,10 @@
- tags: http_parser.c http_parser.h test.c
- ctags $^
-
- -install: library
- +install:
- $(INSTALL) -D http_parser.h $(DESTDIR)$(INCLUDEDIR)/http_parser.h
- $(INSTALL) -D $(LIBNAME) $(DESTDIR)$(LIBDIR)/$(LIBNAME)
- + $(INSTALL) -D libhttp_parser.a $(DESTDIR)$(LIBDIR)/libhttp_parser.a
- ln -s $(LIBNAME) $(DESTDIR)$(LIBDIR)/$(SONAME)
- ln -s $(LIBNAME) $(DESTDIR)$(LIBDIR)/$(SOLIBNAME).$(SOEXT)
-
|