run-testsuite 453 B

1234567891011121314151617
  1. #!/usr/bin/make -f
  2. CPPFLAGS = $(shell dpkg-buildflags --get CPPFLAGS) -DHTTP_PARSER_STRICT=0
  3. CFLAGS = $(shell dpkg-buildflags --get CFLAGS)
  4. LDFLAGS = $(shell dpkg-buildflags --get LDFLAGS)
  5. all: test_auto
  6. ./test_auto
  7. test_auto: test_auto.o
  8. $(CC) $(CFLAGS) $(LDFLAGS) $< -lhttp_parser -o $@
  9. test_auto.o: test_auto.c
  10. $(CC) $(CFLAGS) $(CPPFLAGS) -c $< -o $@
  11. test_auto.c: test.c
  12. sed -e 's/#include "http_parser.h"/#include <http_parser.h>/' <$< >$@