typo-fixes.patch 3.6 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586
  1. Description: Typo fixes
  2. Author: Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
  3. Date: 2017-11-04
  4. Forwarded: https://github.com/latchset/jose/issues/49
  5. --- a/doc/doxygen/man/man3/jose_cfg.3
  6. +++ b/doc/doxygen/man/man3/jose_cfg.3
  7. @@ -37,7 +37,7 @@
  8. .ti -1c
  9. .RI "void * \fBjose_cfg_get_err_misc\fP (jose_cfg_t *cfg)"
  10. .br
  11. -.RI "Gets the miscelaneous data associated with the current error handler\&. "
  12. +.RI "Gets the miscellaneous data associated with the current error handler\&. "
  13. .ti -1c
  14. .RI "void \fBjose_cfg_err\fP (jose_cfg_t *cfg, uint64_t err, const char *fmt,\&.\&.\&.)"
  15. .br
  16. @@ -116,14 +116,14 @@
  17. .br
  18. \fIerr\fP The error handler function you wish to enable\&.
  19. .br
  20. -\fImisc\fP The miscelaneous data you wish to pass to the error handler\&.
  21. +\fImisc\fP The miscellaneous data you wish to pass to the error handler\&.
  22. .RE
  23. .PP
  24. .SS "void* jose_cfg_get_err_misc (jose_cfg_t * cfg)"
  25. .PP
  26. -Gets the miscelaneous data associated with the current error handler\&.
  27. +Gets the miscellaneous data associated with the current error handler\&.
  28. .PP
  29. \fBParameters:\fP
  30. .RS 4
  31. @@ -132,7 +132,7 @@
  32. .PP
  33. \fBReturns:\fP
  34. .RS 4
  35. -The miscelaneous data associated with the error handler\&.
  36. +The miscellaneous data associated with the error handler\&.
  37. .RE
  38. .PP
  39. --- a/doc/doxygen/man/man3/jose_jwe.3
  40. +++ b/doc/doxygen/man/man3/jose_jwe.3
  41. @@ -146,7 +146,7 @@
  42. .fi
  43. .PP
  44. .PP
  45. -In all the above examples, parameters like which encryption algorithms to use were inferred from our keys\&. Where such an inferrence cannot be made, sensible and secure defaults were chosen automatically\&. If you would like more control over the process, simply set parameters in the appropriate objects (more on this in the function documentation)\&. For example, to enable plaintext compression, you can specify the \fCzip\fP property in the JWE Protected Header:
  46. +In all the above examples, parameters like which encryption algorithms to use were inferred from our keys\&. Where such an inference cannot be made, sensible and secure defaults were chosen automatically\&. If you would like more control over the process, simply set parameters in the appropriate objects (more on this in the function documentation)\&. For example, to enable plaintext compression, you can specify the \fCzip\fP property in the JWE Protected Header:
  47. .PP
  48. .nf
  49. json_t *enc(void *plaintext, size_t len, json_t *jwkset) {
  50. --- a/jose/cfg.h
  51. +++ b/jose/cfg.h
  52. @@ -98,16 +98,16 @@
  53. *
  54. * \param cfg The configuration context.
  55. * \param err The error handler function you wish to enable.
  56. - * \param misc The miscelaneous data you wish to pass to the error handler.
  57. + * \param misc The miscellaneous data you wish to pass to the error handler.
  58. */
  59. void
  60. jose_cfg_set_err_func(jose_cfg_t *cfg, jose_cfg_err_t *err, void *misc);
  61. /**
  62. - * Gets the miscelaneous data associated with the current error handler.
  63. + * Gets the miscellaneous data associated with the current error handler.
  64. *
  65. * \param cfg The configuration context.
  66. - * \return The miscelaneous data associated with the error handler.
  67. + * \return The miscellaneous data associated with the error handler.
  68. */
  69. void *
  70. jose_cfg_get_err_misc(jose_cfg_t *cfg);
  71. --- a/jose/jwe.h
  72. +++ b/jose/jwe.h
  73. @@ -107,7 +107,7 @@
  74. * }
  75. *
  76. * In all the above examples, parameters like which encryption algorithms to
  77. - * use were inferred from our keys. Where such an inferrence cannot be made,
  78. + * use were inferred from our keys. Where such an inference cannot be made,
  79. * sensible and secure defaults were chosen automatically. If you would like
  80. * more control over the process, simply set parameters in the appropriate
  81. * objects (more on this in the function documentation). For example,