2021-11-29.use-asciidoctor-to-build-manpages.patch 1002 B

1234567891011121314151617181920212223242526272829
  1. Subject: Use asciidoctor to build the manpages
  2. Author: Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
  3. Date: 2021-11-29
  4. Forwarded: no
  5. --- a/meson.build
  6. +++ b/meson.build
  7. @@ -39,7 +39,7 @@
  8. threads = dependency('threads')
  9. jansson = dependency('jansson', version: '>=2.10')
  10. libcrypto = dependency('libcrypto', version: '>=1.0.2')
  11. -a2x = find_program('a2x', required: false)
  12. +asciidoctor = find_program('asciidoctor', required: false)
  13. jq = find_program('jq', required: false)
  14. mans = []
  15. @@ -66,10 +66,10 @@
  16. requires: 'jansson',
  17. )
  18. -if a2x.found()
  19. +if asciidoctor.found()
  20. foreach m : mans
  21. custom_target(m.split('/')[-1], input: m + '.adoc', output: m.split('/')[-1],
  22. - command: [a2x, '-f', 'manpage', '-D', meson.current_build_dir(), '@INPUT@'],
  23. + command: [asciidoctor, '--attribute', 'reproducible', '--backend=manpage', '-D', meson.current_build_dir(), '@INPUT@'],
  24. install_dir: join_paths(get_option('mandir'), 'man' + m.split('.')[-1]),
  25. install: true
  26. )