2021-12-01.increase-test-timeout.patch 533 B

123456789101112131415161718192021222324
  1. Subject: Increase timeout values in the test suite
  2. Author: Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
  3. Date: 2021-12-01
  4. Forwarded: https://github.com/latchset/jose/issues/110
  5. --- a/tests/meson.build
  6. +++ b/tests/meson.build
  7. @@ -37,14 +37,14 @@
  8. if p == 'api_b64'
  9. to = 1800
  10. else
  11. - to = 30
  12. + to = 180
  13. endif
  14. test(p, exe, timeout: to)
  15. endforeach
  16. foreach s: scripts
  17. exe = find_program('./' + s)
  18. - test(s, exe, env: e, timeout: 60)
  19. + test(s, exe, env: e, timeout: 900)
  20. endforeach
  21. subdir('issue-75')