Browse Source

Packaging cleanup

* Declare compliance with policy 4.5.1
* Bump debhelper compat level to 13
* Set Rule-Requires-Root: no
* Update debian/watch to format 4
Christoph Biedl 8 months ago
parent
commit
070c56df89
3 changed files with 6 additions and 5 deletions
  1. 0 1
      debian/compat
  2. 3 2
      debian/control
  3. 3 2
      debian/watch

+ 0 - 1
debian/compat

@@ -1 +0,0 @@
-11

+ 3 - 2
debian/control

@@ -1,13 +1,14 @@
 Source: libdigest-ssdeep-perl
 Maintainer: Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
 Homepage: https://metacpan.org/release/Digest-ssdeep
-Standards-Version: 4.2.1
+Standards-Version: 4.5.1
 Vcs-Browser: https://git.in-ulm.de/cbiedl/libdigest-ssdeep-perl
 Vcs-Git: https://git.in-ulm.de/cbiedl/libdigest-ssdeep-perl.git
-Build-Depends: debhelper (>= 11~),
+Build-Depends: debhelper-compat (= 13),
 Build-Depends-Indep:
     libtext-wagnerfischer-perl,
 Priority: optional
+Rules-Requires-Root: no
 Section: perl
 
 Package: libdigest-ssdeep-perl

+ 3 - 2
debian/watch

@@ -1,2 +1,3 @@
-version=3
-https://metacpan.org/release/Digest-ssdeep   .*/Digest-ssdeep-v?(\d[\d.-]*)\.(?:tar(?:\.gz|\.bz2)?|tgz|zip)$
+version=4
+https://metacpan.org/release/Digest-ssdeep \
+    .*/Digest-ssdeep-v?(\d[\d.-]*)@ARCHIVE_EXT@