local.use-asciidoctor-to-build-manpages.patch 810 B

123456789101112131415161718192021222324252627
  1. Subject: Use asciidoctor to build the manpages
  2. Author: Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
  3. Date: 2018-08-11
  4. Bug: https://github.com/latchset/tang/issues/32
  5. --- a/Makefile.am
  6. +++ b/Makefile.am
  7. @@ -20,7 +20,7 @@
  8. $(top_builddir)/%.roff: %.adoc
  9. $(MKDIR_P) $$(dirname $@)
  10. - $(A2X) -v -f manpage $^ -D $(top_builddir)/$$(dirname $@)
  11. + $(A2X) -v --attribute reproducible --backend=manpage $^ -D $(top_builddir)/$$(dirname $@)
  12. $(INSTALL) -m 644 $(top_builddir)/$(@:.roff=) $(top_builddir)/$@
  13. man8_MANS = luksmeta.8
  14. --- a/configure.ac
  15. +++ b/configure.ac
  16. @@ -33,7 +33,7 @@
  17. "
  18. AC_SUBST([LUKSMETA_CFLAGS])
  19. -AC_CHECK_PROGS(A2X, [a2x])
  20. +AC_CHECK_PROGS(A2X, [asciidoctor])
  21. if test "x$A2X" = "x"; then
  22. AC_MSG_WARN([asciidoc / a2x not found -- man pages will not be generated and installed!])