rules 439 B

12345678910111213141516171819202122232425
  1. #!/usr/bin/make -f
  2. export DEB_BUILD_MAINT_OPTIONS = hardening=+all
  3. DPKG_EXPORT_BUILDFLAGS = 1
  4. include /usr/share/dpkg/buildflags.mk
  5. %:
  6. dh $@
  7. # the test target must be called as "check"
  8. override_dh_auto_test:
  9. ifeq (, $(findstring nocheck, $(DEB_BUILD_OPTIONS)))
  10. $(MAKE) check
  11. endif
  12. override_dh_missing:
  13. dh_missing --fail-missing
  14. override_dh_auto_install:
  15. dh_auto_install
  16. # Remove useless files
  17. rm -f debian/tmp/usr/lib/*/*.la