12345678910111213141516171819 |
- Subject: Force creation of LUKS1 containers in test suite
- Origin: v9-3-gaf81262 <https://github.com/latchset/luksmeta/commit/v9-3-gaf81262>
- Upstream-Author: Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
- Date: Sat Sep 28 13:24:11 2019 +0200
- Cryptsetup defaults to LUKS2 since version 2.1, make sure to create
- LUKS1 containers instead by using the "--type luks1" argument.
- --- a/test-luksmeta
- +++ b/test-luksmeta
- @@ -11,7 +11,7 @@
- trap 'onexit' EXIT
-
- truncate -s 4M $tmp
- -echo -n foo | cryptsetup luksFormat $tmp -
- +echo -n foo | cryptsetup luksFormat --type luks1 $tmp -
-
- ! ./luksmeta test -d $tmp
-
|