2021-01-10.adjust-for-new-tang-version.patch 1.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. Subject: Update for newer tang versions
  2. Author: Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
  3. Date: 2021-01-10
  4. Bug: https://github.com/latchset/nagios-tang/pull/4
  5. --- a/meson.build
  6. +++ b/meson.build
  7. @@ -40,13 +40,8 @@
  8. '/usr/libexec/tangd-keygen',
  9. '/usr/local/libexec/tangd-keygen',
  10. ], required: false)
  11. -updt = find_program([
  12. - join_paths(libexecdir, 'tangd-update'),
  13. - '/usr/libexec/tangd-update',
  14. - '/usr/local/libexec/tangd-update',
  15. -], required: false)
  16. -if tang.found() and kgen.found() and updt.found() and actv.found()
  17. +if tang.found() and kgen.found() and actv.found()
  18. env = environment()
  19. env.append('PATH',
  20. meson.current_build_dir(),
  21. --- a/tang
  22. +++ b/tang
  23. @@ -28,15 +28,13 @@
  24. export TMP=`mktemp -d`
  25. mkdir -p $TMP/db
  26. -mkdir -p $TMP/cache
  27. # Generate the server keys
  28. tangd-keygen $TMP/db
  29. -tangd-update $TMP/db $TMP/cache
  30. # Start the server
  31. port=`shuf -i 1024-65536 -n 1`
  32. -systemd-socket-activate --inet -l 127.0.0.1:$port -a $VALGRIND tangd $TMP/cache &
  33. +systemd-socket-activate --inet -l 127.0.0.1:$port -a $VALGRIND tangd $TMP/db &
  34. export PID=$!
  35. sleep 0.5