123456789101112131415161718192021 |
- Subject: Use asciidoctor to build the manpages
- Author: Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
- Date: 2018-10-30
- Bug: https://github.com/latchset/tang/issues/32
- --- a/meson.build
- +++ b/meson.build
- @@ -61,10 +61,10 @@
- warning('Will not run tests due to missing dependencies!')
- endif
-
- -a2x = find_program('a2x', required: false)
- -if a2x.found()
- +asciidoctor = find_program('asciidoctor', required: false)
- +if asciidoctor.found()
- custom_target('nagios-tang.1',
- - command: [a2x, '-f', 'manpage', '-D', meson.current_build_dir(), '@INPUT@'],
- + command: [asciidoctor, '--attribute', 'reproducible', '--backend=manpage', '-D', meson.current_build_dir(), '@INPUT@'],
- install_dir: join_paths(get_option('mandir'), 'man1'),
- input: 'nagios-tang.1.adoc',
- output: 'nagios-tang.1',
|