2020-12-28.install-as-check-tang.patch 1.6 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758
  1. Subject: Install program and manpage as check_tang
  2. Author: Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
  3. Date: 2020-12-28
  4. Bug: https://github.com/latchset/nagios-tang/issues/2
  5. --- a/meson.build
  6. +++ b/meson.build
  7. @@ -63,18 +63,18 @@
  8. asciidoctor = find_program('asciidoctor', required: false)
  9. if asciidoctor.found()
  10. - custom_target('nagios-tang.1',
  11. - command: [asciidoctor, '--attribute', 'reproducible', '--backend=manpage', '-D', meson.current_build_dir(), '@INPUT@'],
  12. + custom_target('check_tang.1',
  13. + command: [asciidoctor, '--attribute', 'reproducible', '--backend=manpage', '-D', meson.current_build_dir(), '@INPUT@', '-o', '@OUTPUT@' ],
  14. install_dir: join_paths(get_option('mandir'), 'man1'),
  15. input: 'nagios-tang.1.adoc',
  16. - output: 'nagios-tang.1',
  17. + output: 'check_tang.1',
  18. install: true,
  19. )
  20. else
  21. warning('Will not install man page due to missing dependencies!')
  22. endif
  23. -executable('tang', 'tang.c',
  24. +executable('check_tang', 'tang.c',
  25. install_dir: join_paths(get_option('libdir'), 'nagios', 'plugins'),
  26. dependencies: [http, jose],
  27. install: true,
  28. --- a/tang
  29. +++ b/tang
  30. @@ -40,4 +40,4 @@
  31. export PID=$!
  32. sleep 0.5
  33. -tang -u http://127.0.0.1:$port
  34. +check_tang -u http://127.0.0.1:$port
  35. --- a/nagios-tang.1.adoc
  36. +++ b/nagios-tang.1.adoc
  37. @@ -4,7 +4,7 @@
  38. == NAME
  39. -nagios-tang - A Nagios plugin for Tang
  40. +check_tang - A Nagios plugin for Tang
  41. == SYNOPSIS
  42. @@ -36,7 +36,7 @@
  43. A simple test against a localhost Tang server:
  44. - $ ./tang -u http://localhost/
  45. + $ check_tang -u http://localhost/
  46. OK|adv=21430 exc=44587 nkeys=2 nsigk=1 nexck=1
  47. == AUTHOR