2020-12-28.use-asciidoctor-to-build-manpages.patch 812 B

123456789101112131415161718192021
  1. Subject: Use asciidoctor to build the manpages
  2. Author: Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
  3. Date: 2020-12-28
  4. Bug: https://github.com/latchset/nagios-tang/issues/3
  5. --- a/meson.build
  6. +++ b/meson.build
  7. @@ -61,10 +61,10 @@
  8. warning('Will not run tests due to missing dependencies!')
  9. endif
  10. -a2x = find_program('a2x', required: false)
  11. -if a2x.found()
  12. +asciidoctor = find_program('asciidoctor', required: false)
  13. +if asciidoctor.found()
  14. custom_target('nagios-tang.1',
  15. - command: [a2x, '-f', 'manpage', '-D', meson.current_build_dir(), '@INPUT@'],
  16. + command: [asciidoctor, '--attribute', 'reproducible', '--backend=manpage', '-D', meson.current_build_dir(), '@INPUT@'],
  17. install_dir: join_paths(get_option('mandir'), 'man1'),
  18. input: 'nagios-tang.1.adoc',
  19. output: 'nagios-tang.1',