Browse Source

Packaging cleanup

* Declare compliance with policy 4.4.1
* Bump to debhelper compat level 12
* Set Rule-Requires-Root: no
* Add Pre-Predepends:, it's populated
* Formatting
Christoph Biedl 1 year ago
parent
commit
ef9528afbf
4 changed files with 13 additions and 8 deletions
  1. 0 1
      debian/compat
  2. 5 4
      debian/control
  3. 2 2
      debian/ngircd.tmpfile
  4. 6 1
      debian/rules

+ 0 - 1
debian/compat

@@ -1 +0,0 @@
-9

+ 5 - 4
debian/control

@@ -1,12 +1,10 @@
 Source: ngircd
 Maintainer: Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
 Homepage: https://ngircd.barton.de/
-Standards-Version: 3.9.8
+Standards-Version: 4.4.1
 Vcs-Browser: https://git.in-ulm.de/cbiedl/ngircd
 Vcs-Git: https://git.in-ulm.de/cbiedl/ngircd.git
-Build-Depends: debhelper (>= 9~),
-    autotools-dev,
-    dh-systemd,
+Build-Depends: debhelper-compat (= 12),
     expect,
     libgnutls28-dev,
     libident-dev,
@@ -15,10 +13,13 @@ Build-Depends: debhelper (>= 9~),
     telnet,
     zlib1g-dev,
 Priority: optional
+Rules-Requires-Root: no
 Section: net
 
 Package: ngircd
 Architecture: any
+Pre-Depends:
+    ${misc:Pre-Depends},
 Depends: ${misc:Depends}, ${shlibs:Depends},
     lsb-base,
 Conflicts:

+ 2 - 2
debian/ngircd.tmpfile

@@ -1,3 +1,3 @@
 
-d   /var/run/ircd   0755    irc irc
-d   /var/run/ngircd 0755    irc irc
+d /var/run/ircd   0755 irc irc
+d /var/run/ngircd 0755 irc irc

+ 6 - 1
debian/rules

@@ -5,7 +5,12 @@ export DEB_BUILD_MAINT_OPTIONS = hardening=+all
 export CFLAGS += -DBIRTHDATE=$(SOURCE_DATE_EPOCH)
 
 %:
-	dh $@ --with systemd
+	dh $@
+
+# disable dh_autoreconf since upstream's configure.ac uses the
+# de-ANSI-fication which was removed in autoconf a while ago.
+# See also https://github.com/ngircd/ngircd/issues/261
+override_dh_autoreconf:
 
 override_dh_auto_configure:
 	dh_auto_configure -- \