1234567891011121314151617181920212223242526272829303132333435363738394041 |
- #!/usr/bin/make -f
- export CFLAGS := $(shell dpkg-buildflags --get CFLAGS)
- export DEB_BUILD_MAINT_OPTIONS = hardening=+all
- export CFLAGS += -DBIRTHDATE=$(SOURCE_DATE_EPOCH)
- %:
- dh $@
- # disable dh_autoreconf since upstream's configure.ac uses the
- # de-ANSI-fication which was removed in autoconf a while ago.
- # See also https://github.com/ngircd/ngircd/issues/261
- override_dh_autoreconf:
- override_dh_auto_configure:
- dh_auto_configure -- \
- --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
- --prefix=/usr \
- --mandir=\$${prefix}/share/man \
- --infodir=\$${prefix}/share/info \
- --sysconfdir=/etc/ngircd \
- --with-gnutls \
- --with-ident \
- --with-pam \
- --enable-ipv6
- override_dh_auto_install:
- dh_auto_install
- # install config and sample motd file
- install -m 640 -D $(CURDIR)/debian/ngircd.conf \
- $(CURDIR)/debian/ngircd/etc/ngircd/ngircd.conf
- install -m 640 -D $(CURDIR)/debian/ngircd.motd \
- $(CURDIR)/debian/ngircd/etc/ngircd/ngircd.motd
- # make lintian happy
- rm $(CURDIR)/debian/ngircd/usr/share/doc/ngircd/COPYING
- mv $(CURDIR)/debian/ngircd/usr/share/doc/ngircd/ChangeLog \
- $(CURDIR)/debian/ngircd/usr/share/doc/ngircd/changelog
- # Commands.txt is read by the daemon
- override_dh_compress:
- dh_compress -XCommands.txt
|