12345678910111213141516171819202122232425262728293031323334353637383940414243 |
- #!/usr/bin/make -f
- export CFLAGS:=$(shell dpkg-buildflags --get CFLAGS)
- export DEB_BUILD_MAINT_OPTIONS = hardening=+all
- ifeq ($(SOURCE_DATE_EPOCH),)
- # workaround until SOURCE_DATE_EPOCH is available
- $(info SOURCE_DATE_EPOCH is not set, using changelog date instead)
- export CFLAGS += -DBIRTHDATE=$(shell date --date="$$(dpkg-parsechangelog --count 1 --show-field Date)" +%s)
- else
- export CFLAGS += -DBIRTHDATE=$(SOURCE_DATE_EPOCH)
- endif
- %:
- dh $@ --with systemd
- override_dh_auto_configure:
- dh_auto_configure -- \
- --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
- --prefix=/usr \
- --mandir=\$${prefix}/share/man \
- --infodir=\$${prefix}/share/info \
- --sysconfdir=/etc/ngircd \
- --with-gnutls \
- --with-ident \
- --with-pam \
- --enable-ipv6
- override_dh_auto_install:
- dh_auto_install
- # install config and sample motd file
- install -m 640 -D $(CURDIR)/debian/ngircd.conf \
- $(CURDIR)/debian/ngircd/etc/ngircd/ngircd.conf
- install -m 640 -D $(CURDIR)/debian/ngircd.motd \
- $(CURDIR)/debian/ngircd/etc/ngircd/ngircd.motd
- # make lintian happy
- rm $(CURDIR)/debian/ngircd/usr/share/doc/ngircd/COPYING
- mv $(CURDIR)/debian/ngircd/usr/share/doc/ngircd/ChangeLog \
- $(CURDIR)/debian/ngircd/usr/share/doc/ngircd/changelog
- # Commands.txt is read by the daemon
- override_dh_compress:
- dh_compress -XCommands.txt
|