rules 1.1 KB

123456789101112131415161718192021222324252627282930313233343536
  1. #!/usr/bin/make -f
  2. export CFLAGS:=$(shell dpkg-buildflags --get CFLAGS)
  3. export DEB_BUILD_MAINT_OPTIONS = hardening=+all
  4. export CFLAGS += -DBIRTHDATE=$(SOURCE_DATE_EPOCH)
  5. %:
  6. dh $@ --with systemd
  7. override_dh_auto_configure:
  8. dh_auto_configure -- \
  9. --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
  10. --prefix=/usr \
  11. --mandir=\$${prefix}/share/man \
  12. --infodir=\$${prefix}/share/info \
  13. --sysconfdir=/etc/ngircd \
  14. --with-gnutls \
  15. --with-ident \
  16. --with-pam \
  17. --enable-ipv6
  18. override_dh_auto_install:
  19. dh_auto_install
  20. # install config and sample motd file
  21. install -m 640 -D $(CURDIR)/debian/ngircd.conf \
  22. $(CURDIR)/debian/ngircd/etc/ngircd/ngircd.conf
  23. install -m 640 -D $(CURDIR)/debian/ngircd.motd \
  24. $(CURDIR)/debian/ngircd/etc/ngircd/ngircd.motd
  25. # make lintian happy
  26. rm $(CURDIR)/debian/ngircd/usr/share/doc/ngircd/COPYING
  27. mv $(CURDIR)/debian/ngircd/usr/share/doc/ngircd/ChangeLog \
  28. $(CURDIR)/debian/ngircd/usr/share/doc/ngircd/changelog
  29. # Commands.txt is read by the daemon
  30. override_dh_compress:
  31. dh_compress -XCommands.txt