fix-ipv6-only-buildhost.patch 531 B

1234567891011121314151617
  1. Subject: Fix race in testsuite
  2. Author: Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
  3. Date: 2020-07-25
  4. Bug-Debian: https://bugs.debian.org/964276
  5. Forwarded: https://github.com/ngircd/ngircd/issues/281
  6. --- a/src/ngircd/resolve.c
  7. +++ b/src/ngircd/resolve.c
  8. @@ -246,7 +246,7 @@
  9. static struct addrinfo hints;
  10. #ifdef AI_ADDRCONFIG /* glibc has this, but not e.g. netbsd 4.0 */
  11. - hints.ai_flags = AI_ADDRCONFIG;
  12. +/* hints.ai_flags = AI_ADDRCONFIG; */
  13. #endif
  14. hints.ai_socktype = SOCK_STREAM;
  15. hints.ai_protocol = IPPROTO_TCP;