ngircd.spec 1.5 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455
  1. %define name ngircd
  2. %define version 0.12.1
  3. %define release 1
  4. %define prefix %{_prefix}
  5. Summary: A lightweight daemon for the Internet Relay Chat (IRC)
  6. Name: %{name}
  7. Version: %{version}
  8. Release: %{release}
  9. Copyright: GPL
  10. Group: Networking/Daemons
  11. URL: http://arthur.ath.cx/~alex/ngircd/
  12. Source: %{name}-%{version}.tar.gz
  13. Packager: Sean Reifschneider <jafo-rpms@tummy.com>
  14. BuildRoot: /var/tmp/%{name}-root
  15. %description
  16. ngIRCd is a free open source daemon for the Internet Relay Chat (IRC),
  17. developed under the GNU General Public License (GPL). It's written from
  18. scratch and is not based upon the original IRCd like many others.
  19. Advantages:
  20. - no problems with servers using changing/non-static IP addresses.
  21. - small and lean configuration file.
  22. - free, modern and open source C code.
  23. - still under active development.
  24. ngIRCd is compatible to the "original" ircd 2.10.3p3, so you can run
  25. mixed networks.
  26. %prep
  27. %setup
  28. %build
  29. %configure
  30. make
  31. %install
  32. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf "$RPM_BUILD_ROOT"
  33. %makeinstall
  34. (
  35. cd "$RPM_BUILD_ROOT"
  36. ( cd usr/sbin; mv *-ngircd ngircd )
  37. ( cd usr/share/man/man5; mv *-ngircd.conf.5 ngircd.conf.5 )
  38. ( cd usr/share/man/man8; mv *-ngircd.8 ngircd.8 )
  39. )
  40. %clean
  41. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf "$RPM_BUILD_ROOT"
  42. %files
  43. %defattr(755,root,root)
  44. %doc AUTHORS COPYING ChangeLog INSTALL NEWS README
  45. %config(noreplace) /etc
  46. %{_prefix}/sbin
  47. %{_prefix}/share/man/