ngircd.spec 1.7 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061
  1. %define name ngircd
  2. %define version 19.2
  3. %define release 1
  4. %define prefix %{_prefix}
  5. Summary: A lightweight daemon for the Internet Relay Chat (IRC)
  6. Name: %{name}
  7. Version: %{version}
  8. Release: %{release}
  9. License: GPLv2+
  10. Group: System Environment/Daemons
  11. URL: http://ngircd.barton.de/
  12. Source: %{name}-%{version}.tar.gz
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  14. BuildRequires: zlib-devel, openssl-devel
  15. %description
  16. This package provides ngIRCd, a lightweight Internet Relay Chat
  17. server for small or private networks. It is simple to configure, can
  18. cope with dynamic IP addresses, and supports IPv6 as well as SSL. It
  19. is written from scratch, not based on the original IRCd and quite
  20. portable.
  21. Advantages:
  22. - well arranged (lean) configuration file
  23. - simple to build/install, configure and maintain
  24. - supports IPv6 and SSL
  25. - no problems with servers that have dynamic IP addresses
  26. - freely available, modern, portable and tidy C-source
  27. - ngIRCd is being actively developed since 11 years.
  28. %prep
  29. %setup -q
  30. %build
  31. %configure \
  32. --with-zlib \
  33. --with-openssl
  34. make %{?_smp_mflags}
  35. %install
  36. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf "$RPM_BUILD_ROOT"
  37. %makeinstall
  38. (
  39. cd "$RPM_BUILD_ROOT"
  40. ( cd usr/sbin; mv *-ngircd ngircd )
  41. ( cd usr/share/man/man5; mv *-ngircd.conf.5 ngircd.conf.5 )
  42. ( cd usr/share/man/man8; mv *-ngircd.8 ngircd.8 )
  43. rm -fr usr/share/doc/ngircd
  44. )
  45. %clean
  46. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf "$RPM_BUILD_ROOT"
  47. %files
  48. %defattr(755,root,root)
  49. %doc AUTHORS COPYING ChangeLog INSTALL NEWS README doc/*
  50. %config(noreplace) /etc
  51. %{_prefix}/sbin
  52. %{_mandir}/man5/ngircd.conf*
  53. %{_mandir}/man8/ngircd.8*