04-nicklength.dpatch 1.5 KB

1234567891011121314151617181920212223242526272829303132
  1. #! /bin/sh /usr/share/dpatch/dpatch-run
  2. ## 99-unnamed.dpatch by <mario@localhost.localdomain>
  3. ##
  4. ## All lines beginning with `## DP:' are a description of the patch.
  5. ## DP: No description.
  6. @DPATCH@
  7. diff --context -r ngircd-0.9.2/src/ngircd/defines.h ngircd-0.9.2-new/src/ngircd/defines.h
  8. *** ngircd-0.9.2/src/ngircd/defines.h 2005-07-05 23:58:25.000000000 +0100
  9. --- ngircd-0.9.2-new/src/ngircd/defines.h 2006-03-05 00:45:35.000000000 +0000
  10. ***************
  11. *** 41,49 ****
  12. #define CONNECTION_POOL 100 /* size of default connection pool */
  13. #define CLIENT_ID_LEN 64 /* max. length of an IRC ID; see RFC 2812, 1.1 and 1.2.1 */
  14. ! #define CLIENT_NICK_LEN 10 /* max. nick length; see. RFC 2812, 1.2.1 */
  15. #define CLIENT_PASS_LEN 21 /* max. password length */
  16. ! #define CLIENT_USER_LEN 10 /* Max. length of user name ("login")
  17. see RFC 2812, section 1.2.1 */
  18. #define CLIENT_NAME_LEN 32 /* max. length of "real names" */
  19. #define CLIENT_HOST_LEN 64 /* max. host name length */
  20. --- 41,49 ----
  21. #define CONNECTION_POOL 100 /* size of default connection pool */
  22. #define CLIENT_ID_LEN 64 /* max. length of an IRC ID; see RFC 2812, 1.1 and 1.2.1 */
  23. ! #define CLIENT_NICK_LEN 16 /* max. nick length; see. RFC 2812, 1.2.1 */
  24. #define CLIENT_PASS_LEN 21 /* max. password length */
  25. ! #define CLIENT_USER_LEN 16 /* Max. length of user name ("login")
  26. see RFC 2812, section 1.2.1 */
  27. #define CLIENT_NAME_LEN 32 /* max. length of "real names" */
  28. #define CLIENT_HOST_LEN 64 /* max. host name length */