123456789101112131415161718192021222324 |
- Subject: Allow reproducible builds by introducing a BIRTHDATE constant
- Author: Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
- Date: Tue Aug 25 18:03:23 2015 +0200
- Forwarded: http://arthur.barton.de/pipermail/ngircd-ml/2015-August/000819.html
- --- a/src/ngircd/irc-info.c
- +++ b/src/ngircd/irc-info.c
- @@ -556,7 +556,15 @@
- NGIRCd_Version))
- return DISCONNECTED;
-
- -#if defined(__DATE__) && defined(__TIME__)
- +#if defined(BIRTHDATE)
- + char t_str[60];
- + time_t t = BIRTHDATE;
- + (void)strftime(t_str, sizeof(t_str), "%a %b %d %Y at %H:%M:%S (%Z)",
- + localtime(&t));
- + snprintf(msg, sizeof(msg), "Birth Date: %s", t_str);
- + if (!IRC_WriteStrClient(Client, RPL_INFO_MSG, Client_ID(prefix), msg))
- + return DISCONNECTED;
- +#elif defined(__DATE__) && defined(__TIME__)
- snprintf(msg, sizeof(msg), "Birth Date: %s at %s", __DATE__, __TIME__);
- if (!IRC_WriteStrClient(Client, RPL_INFO_MSG, Client_ID(prefix), msg))
- return DISCONNECTED;
|