rules 1.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778
  1. #!/usr/bin/make -f
  2. # MAde with the aid of dh_make, by Craig Small
  3. # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
  4. # Some lines taken from debmake, by Cristoph Lameter.
  5. # Uncomment this to turn on verbose mode.
  6. #export DH_VERBOSE=1
  7. build: build-stamp
  8. build-stamp:
  9. dh_testdir
  10. ./configure --prefix=/usr --mandir=/usr/share/man \
  11. --with-libwrap --with-bcrelay
  12. # Add here commands to compile the package.
  13. $(MAKE)
  14. touch build-stamp
  15. clean:
  16. dh_testdir
  17. dh_testroot
  18. rm -f build-stamp install-stamp
  19. # Add here commands to clean up after the build process.
  20. -$(MAKE) distclean
  21. dh_clean
  22. install: install-stamp
  23. install-stamp: build-stamp
  24. dh_testdir
  25. dh_testroot
  26. dh_clean -k
  27. dh_installdirs
  28. # Add here commands to install the package into debian/tmp.
  29. $(MAKE) install prefix=`pwd`/debian/tmp/usr mandir=`pwd`/debian/tmp/usr/share/man
  30. cp debian/pptpd.conf `pwd`/debian/tmp/etc
  31. cp debian/pptpd-options `pwd`/debian/tmp/etc/ppp
  32. #cp debian/pptpdconfig.pl `pwd`/debian/tmp/usr/sbin
  33. touch install-stamp
  34. # Build architecture-independent files here.
  35. binary-indep: build install
  36. # We have nothing to do by default.
  37. # Build architecture-dependent files here.
  38. binary-arch: build install
  39. # dh_testversion
  40. dh_testdir
  41. dh_testroot
  42. dh_installdocs
  43. # mv `pwd`/debian/tmp/usr/share/doc/pptpd/html/*.txt `pwd`/debian/tmp/usr/share/doc/pptpd/
  44. dh_installexamples
  45. # dh_installmenu
  46. # dh_installemacsen
  47. dh_installinit
  48. # dh_installcron
  49. dh_installmanpages
  50. # dh_installdebconf
  51. # dh_undocumented
  52. dh_installchangelogs -k ChangeLog
  53. dh_strip
  54. dh_compress
  55. dh_fixperms
  56. dh_installdeb
  57. dh_shlibdeps
  58. dh_gencontrol
  59. # dh_makeshlibs
  60. dh_md5sums
  61. dh_builddeb
  62. source diff:
  63. @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
  64. binary: binary-indep binary-arch
  65. .PHONY: build clean binary-indep binary-arch binary