rules 593 B

1234567891011121314151617181920212223242526
  1. #!/usr/bin/make -f
  2. export DEB_BUILD_MAINT_OPTIONS = hardening=+all
  3. %:
  4. dh $@ --with systemd --with autoreconf --with ppp
  5. override_dh_auto_configure:
  6. dh_auto_configure -- \
  7. --prefix=/usr \
  8. --mandir=/usr/share/man \
  9. --with-libwrap \
  10. --enable-bcrelay
  11. override_dh_install:
  12. dh_install --fail-missing
  13. install -D -m 644 debian/modules-load.conf debian/pptpd/etc/modules-load.d/pptpd.conf
  14. override_dh_installdocs:
  15. dh_installdocs --exclude=test.txt
  16. override_dh_installinit:
  17. dh_installinit -- start 20 2 3 4 5 . stop 20 1 .
  18. override_dh_systemd_enable:
  19. dh_systemd_enable --no-enable