build_hardening-flags.patch 1.0 KB

1234567891011121314151617181920212223242526272829303132
  1. Subject: Enable hardened build flags
  2. Author: Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
  3. Bug-Debian: http://bugs.debian.org/656650
  4. Forwarded: not-needed
  5. Last-Update: 2015-08-24
  6. --- a/Makefile.am
  7. +++ b/Makefile.am
  8. @@ -11,9 +11,10 @@
  9. ## warning with -Wmissing-prototypes).
  10. ## -Wmissing-prototypes removed (eg, Linux 2.2.6 headers
  11. ## aren't up to it).
  12. -CFLAGS = -O2 -fno-builtin -Wall -DSBINDIR='"$(sbindir)"'
  13. +#CFLAGS = -O2 -fno-builtin -Wall -DSBINDIR='"$(sbindir)"'
  14. #CFLAGS = -O2 -fno-builtin -Wall -ansi -DSBINDIR='"$(sbindir)"'
  15. #CFLAGS = -O2 -fno-builtin -Wall -ansi -pedantic -Wmissing-prototypes -Werror -DSBINDIR='"$(sbindir)"'
  16. +CPPFLAGS = -DSBINDIR='"$(sbindir)"'
  17. man_MANS = pptpctrl.8 pptpd.8 pptpd.conf.5 bcrelay.8
  18. --- a/plugins/Makefile
  19. +++ b/plugins/Makefile
  20. @@ -1,7 +1,7 @@
  21. CC = gcc
  22. COPTS = -O2 -g
  23. -CFLAGS = $(COPTS) -I.. -I../../include -fPIC
  24. -LDFLAGS = -shared
  25. +CFLAGS += $(COPTS) -I.. -I../../include -fPIC
  26. +LDFLAGS += -shared
  27. LDADD = -lutil
  28. INSTALL = install -o root
  29. prefix = /usr/local