rules 2.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788
  1. #!/usr/bin/make -f
  2. # MAde with the aid of dh_make, by Craig Small
  3. # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
  4. # Some lines taken from debmake, by Cristoph Lameter.
  5. export DEB_BUILD_HARDENING=1
  6. export CFLAGS:=$(shell dpkg-buildflags --get CFLAGS)
  7. export LDFLAGS:=$(shell dpkg-buildflags --get LDFLAGS)
  8. # Uncomment this to turn on verbose mode.
  9. #export DH_VERBOSE=1
  10. export DH_COMPAT=4
  11. build: build-stamp
  12. build-stamp:
  13. dh_testdir
  14. autoreconf
  15. ./configure --prefix=/usr --mandir=/usr/share/man \
  16. --with-libwrap --enable-bcrelay
  17. # Add here commands to compile the package.
  18. $(MAKE)
  19. touch build-stamp
  20. clean:
  21. dh_testdir
  22. dh_testroot
  23. rm -f build-stamp install-stamp
  24. rm -f debian/conffiles
  25. # Add here commands to clean up after the build process.
  26. -$(MAKE) distclean
  27. dh_clean
  28. install: install-stamp
  29. install-stamp: build-stamp
  30. dh_testdir
  31. dh_testroot
  32. dh_clean -k
  33. dh_installdirs
  34. # Add here commands to install the package into debian/tmp.
  35. $(MAKE) install prefix=`pwd`/debian/pptpd/usr mandir=`pwd`/debian/pptpd/usr/share/man
  36. cp debian/pptpd.conf `pwd`/debian/pptpd/etc
  37. cp debian/pptpd-options `pwd`/debian/pptpd/etc/ppp
  38. #cp debian/pptpdconfig.pl `pwd`/debian/tmp/usr/sbin
  39. # split bcrelay into its own package
  40. mv debian/pptpd/usr/sbin/bcrelay debian/bcrelay/usr/sbin
  41. touch install-stamp
  42. # Build architecture-independent files here.
  43. binary-indep: build install
  44. # We have nothing to do by default.
  45. # Build architecture-dependent files here.
  46. binary-arch: build install
  47. # dh_testversion
  48. dh_testdir
  49. dh_testroot
  50. dh_installdocs
  51. dh_installexamples -ppptpd
  52. # dh_installmenu
  53. # dh_installemacsen
  54. dh_installinit -ppptpd
  55. # dh_installcron
  56. dh_installman -ppptpd
  57. # dh_installdebconf
  58. # dh_undocumented
  59. dh_installchangelogs -k ChangeLog
  60. dh_strip
  61. dh_compress
  62. dh_fixperms
  63. dh_installdeb
  64. dh_shlibdeps
  65. dh_gencontrol
  66. # dh_makeshlibs
  67. dh_md5sums
  68. dh_builddeb
  69. source diff:
  70. @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
  71. binary: binary-indep binary-arch
  72. .PHONY: build clean binary-indep binary-arch binary