12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788 |
- #!/usr/bin/make -f
- # MAde with the aid of dh_make, by Craig Small
- # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
- # Some lines taken from debmake, by Cristoph Lameter.
- export DEB_BUILD_HARDENING=1
- export CFLAGS:=$(shell dpkg-buildflags --get CFLAGS)
- export LDFLAGS:=$(shell dpkg-buildflags --get LDFLAGS)
- # Uncomment this to turn on verbose mode.
- #export DH_VERBOSE=1
- export DH_COMPAT=4
- build: build-stamp
- build-stamp:
- dh_testdir
- autoreconf
- ./configure --prefix=/usr --mandir=/usr/share/man \
- --with-libwrap --enable-bcrelay
- # Add here commands to compile the package.
- $(MAKE)
- touch build-stamp
- clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp install-stamp
- rm -f debian/conffiles
- # Add here commands to clean up after the build process.
- -$(MAKE) distclean
- dh_clean
- install: install-stamp
- install-stamp: build-stamp
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
- # Add here commands to install the package into debian/tmp.
- $(MAKE) install prefix=`pwd`/debian/pptpd/usr mandir=`pwd`/debian/pptpd/usr/share/man
- cp debian/pptpd.conf `pwd`/debian/pptpd/etc
- cp debian/pptpd-options `pwd`/debian/pptpd/etc/ppp
- #cp debian/pptpdconfig.pl `pwd`/debian/tmp/usr/sbin
- # split bcrelay into its own package
- mv debian/pptpd/usr/sbin/bcrelay debian/bcrelay/usr/sbin
-
- touch install-stamp
- # Build architecture-independent files here.
- binary-indep: build install
- # We have nothing to do by default.
- # Build architecture-dependent files here.
- binary-arch: build install
- # dh_testversion
- dh_testdir
- dh_testroot
- dh_installdocs
- dh_installexamples -ppptpd
- # dh_installmenu
- # dh_installemacsen
- dh_installinit -ppptpd
- # dh_installcron
- dh_installman -ppptpd
- # dh_installdebconf
- # dh_undocumented
- dh_installchangelogs -k ChangeLog
- dh_strip
- dh_compress
- dh_fixperms
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- # dh_makeshlibs
- dh_md5sums
- dh_builddeb
- source diff:
- @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
- binary: binary-indep binary-arch
- .PHONY: build clean binary-indep binary-arch binary
|