cherry-pick.1.4.0-14-gb84360b.pptpctrl-exit-when-bailing.patch 646 B

123456789101112131415161718192021222324
  1. Subject: Pptpctrl: exit when bailing
  2. Origin: 1.4.0-14-gb84360b
  3. Upstream-Author: James Cameron <quozl@laptop.org>
  4. Date: Sat Oct 18 15:08:00 2014 +1100
  5. Commit 0770455 in 2004 removed the call to exit, and so now pptpctrl
  6. continues instead of terminating.
  7. http://sourceforge.net/p/poptop/bugs/51/
  8. Reported-by: Gavin Wan <gavin-wan-nd@users.sf.net>
  9. Signed-off-by: James Cameron <quozl@laptop.org>
  10. --- a/pptpctrl.c
  11. +++ b/pptpctrl.c
  12. @@ -545,6 +545,8 @@
  13. if (pptpctrl_debug)
  14. syslog(LOG_DEBUG, "CTRL: Exiting now");
  15. +
  16. + exit((GET_VALUE(PAC, call_id_pair) == htons(-1)) ? 0 : 1);
  17. }
  18. /*