cherry-pick.1.4.0-20-g4da603d.propagate-cc-to-subdirectories.patch 930 B

123456789101112131415161718192021222324252627
  1. Subject: Propagate CC to subdirectories
  2. Origin: 1.4.0-20-g4da603d
  3. Upstream-Author: Helmut Grohne <helmut@subdivi.de>
  4. Date: Wed Jan 3 06:37:56 2018 +1100
  5. Bug-Debian: https://bugs.debian.org/886160
  6. pptpd fails to cross build from source, because it fails to propagate CC
  7. to plugins/Makefile. It is correctly detected by configure and correctly
  8. forwarded to Makefile.am, but fails being forwarded to plugins/Makefile.
  9. After making that forwarding explicit, pptpd cross builds successfully.
  10. Fixes Debian #886160.
  11. Signed-off-by: James Cameron <quozl@laptop.org>
  12. --- a/Makefile.am
  13. +++ b/Makefile.am
  14. @@ -54,7 +54,7 @@
  15. subdirs = plugins
  16. all-local:
  17. - for d in $(subdirs); do $(MAKE) $(MFLAGS) -C $$d all; done
  18. + for d in $(subdirs); do $(MAKE) $(MFLAGS) 'CC=$(CC)' -C $$d all; done
  19. install-exec-local:
  20. for d in $(subdirs); do $(MAKE) $(MFLAGS) -C $$d prefix=$(prefix) DESTDIR=$(DESTDIR) install; done