1234567891011121314151617181920212223242526272829 |
- Description: "remotenumber" support
- Author: Igor A Tarasov <develop@dicr.org>
- Author: Michael Poetters <michael@poetters.net>
- Forwarded: http://sourceforge.net/mailarchive/forum.php?thread_name=1360193861%40msgid.manchmal.in-ulm.de&forum_name=poptop-server
- Bug-Debian: http://bugs.debian.org/610375
- Bug-Debian: http://bugs.debian.org/625459
- Bug-Ubuntu: https://bugs.launchpad.net/ubuntu/+source/pptpd/+bug/704245
- --- a/pptpctrl.c
- +++ b/pptpctrl.c
- @@ -657,7 +657,7 @@
- */
- static void launch_pppd(char **pppaddrs, struct in_addr *inetaddrs)
- {
- - char *pppd_argv[14];
- + char *pppd_argv[16];
- int an = 0;
- sigset_t sigs;
-
- @@ -778,6 +778,9 @@
- pppd_argv[an++] = inet_ntoa(inetaddrs[1]);
- }
-
- + pppd_argv[an++] = "remotenumber";
- + pppd_argv[an++] = inet_ntoa(inetaddrs[1]);
- +
- /* argv arrays must always be NULL terminated */
- pppd_argv[an++] = NULL;
- /* make sure SIGCHLD is unblocked, pppd does not expect it */
|