1234567891011121314151617181920212223 |
- Description: Fix "Binary trash when launching ppp"
- Author: "tevaum@gmail.com" <tevaum@gmail.com>
- Forwarded: no
- Bug-Debian: http://bugs.debian.org/693136
- --- a/pptpctrl.c
- +++ b/pptpctrl.c
- @@ -660,6 +660,7 @@
- char *pppd_argv[16];
- int an = 0;
- sigset_t sigs;
- + char pppInterfaceIPs[33];
-
- pppd_argv[an++] = ppp_binary;
-
- @@ -760,7 +761,6 @@
- }
-
- if (*pppaddrs[0] || *pppaddrs[1]) {
- - char pppInterfaceIPs[33];
- sprintf(pppInterfaceIPs, "%s:%s", pppaddrs[0], pppaddrs[1]);
- pppd_argv[an++] = pppInterfaceIPs;
- }
|