rules 1.9 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283
  1. #!/usr/bin/make -f
  2. # MAde with the aid of dh_make, by Craig Small
  3. # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
  4. # Some lines taken from debmake, by Cristoph Lameter.
  5. # Uncomment this to turn on verbose mode.
  6. #export DH_VERBOSE=1
  7. export DH_COMPAT=4
  8. build: build-stamp
  9. build-stamp:
  10. dh_testdir
  11. ./configure --prefix=/usr --mandir=/usr/share/man \
  12. --with-libwrap --enable-bcrelay
  13. # Add here commands to compile the package.
  14. $(MAKE)
  15. touch build-stamp
  16. clean:
  17. dh_testdir
  18. dh_testroot
  19. rm -f build-stamp install-stamp
  20. rm -f debian/conffiles
  21. # Add here commands to clean up after the build process.
  22. -$(MAKE) distclean
  23. dh_clean
  24. install: install-stamp
  25. install-stamp: build-stamp
  26. dh_testdir
  27. dh_testroot
  28. dh_clean -k
  29. dh_installdirs
  30. # Add here commands to install the package into debian/tmp.
  31. $(MAKE) install prefix=`pwd`/debian/pptpd/usr mandir=`pwd`/debian/pptpd/usr/share/man
  32. cp debian/pptpd.conf `pwd`/debian/pptpd/etc
  33. cp debian/pptpd-options `pwd`/debian/pptpd/etc/ppp
  34. #cp debian/pptpdconfig.pl `pwd`/debian/tmp/usr/sbin
  35. # split bcrelay into its own package
  36. mv debian/pptpd/usr/sbin/bcrelay debian/bcrelay/usr/sbin
  37. touch install-stamp
  38. # Build architecture-independent files here.
  39. binary-indep: build install
  40. # We have nothing to do by default.
  41. # Build architecture-dependent files here.
  42. binary-arch: build install
  43. # dh_testversion
  44. dh_testdir
  45. dh_testroot
  46. dh_installdocs
  47. dh_installexamples -ppptpd
  48. # dh_installmenu
  49. # dh_installemacsen
  50. dh_installinit -ppptpd
  51. # dh_installcron
  52. dh_installman -ppptpd
  53. # dh_installdebconf
  54. # dh_undocumented
  55. dh_installchangelogs -k ChangeLog
  56. dh_strip
  57. dh_compress
  58. dh_fixperms
  59. dh_installdeb
  60. dh_shlibdeps
  61. dh_gencontrol
  62. # dh_makeshlibs
  63. dh_md5sums
  64. dh_builddeb
  65. source diff:
  66. @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
  67. binary: binary-indep binary-arch
  68. .PHONY: build clean binary-indep binary-arch binary