build_hardening-flags.patch 1009 B

12345678910111213141516171819202122232425262728293031
  1. Description: Enable hardened build flags
  2. Author: Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
  3. Forwarded: not-needed
  4. Bug-Debian: http://bugs.debian.org/656650
  5. --- a/Makefile.am
  6. +++ b/Makefile.am
  7. @@ -11,9 +11,10 @@
  8. ## warning with -Wmissing-prototypes).
  9. ## -Wmissing-prototypes removed (eg, Linux 2.2.6 headers
  10. ## aren't up to it).
  11. -CFLAGS = -O2 -fno-builtin -Wall -DSBINDIR='"$(sbindir)"'
  12. +#CFLAGS = -O2 -fno-builtin -Wall -DSBINDIR='"$(sbindir)"'
  13. #CFLAGS = -O2 -fno-builtin -Wall -ansi -DSBINDIR='"$(sbindir)"'
  14. #CFLAGS = -O2 -fno-builtin -Wall -ansi -pedantic -Wmissing-prototypes -Werror -DSBINDIR='"$(sbindir)"'
  15. +CPPFLAGS = -DSBINDIR='"$(sbindir)"'
  16. man_MANS = pptpctrl.8 pptpd.8 pptpd.conf.5 bcrelay.8
  17. --- a/plugins/Makefile
  18. +++ b/plugins/Makefile
  19. @@ -1,7 +1,7 @@
  20. CC = gcc
  21. COPTS = -O2 -g
  22. -CFLAGS = $(COPTS) -I.. -I../../include -fPIC
  23. -LDFLAGS = -shared
  24. +CFLAGS += $(COPTS) -I.. -I../../include -fPIC
  25. +LDFLAGS += -shared
  26. LDADD = -lutil
  27. INSTALL = install -o root
  28. prefix = /usr/local