pptpd.postinst 576 B

1234567891011121314151617181920212223242526272829
  1. #!/bin/sh
  2. set -e
  3. dpkg-maintscript-helper mv_conffile \
  4. /etc/modprobe.d/pptpd.conf \
  5. /etc/modules-load.d/pptpd.conf \
  6. 1.4.0-9~ \
  7. -- "$@"
  8. case "$1" in
  9. configure)
  10. # load the module configured in /etc/modules-load.d/pptpd.conf
  11. if [ -d /run/systemd/system ] ; then
  12. deb-systemd-invoke restart systemd-modules-load.service
  13. else
  14. modprobe nf_nat_pptp 2>/dev/null || true
  15. fi
  16. ;;
  17. abort-upgrade|abort-remove|abort-deconfigure)
  18. ;;
  19. *)
  20. echo "postinst called with unknown argument '$1'"
  21. exit 1
  22. ;;
  23. esac
  24. #DEBHELPER#
  25. exit 0