123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778 |
- #!/usr/bin/make -f
- # MAde with the aid of dh_make, by Craig Small
- # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
- # Some lines taken from debmake, by Cristoph Lameter.
- # Uncomment this to turn on verbose mode.
- #export DH_VERBOSE=1
- build: build-stamp
- build-stamp:
- dh_testdir
- ./configure --prefix=/usr --mandir=/usr/share/man \
- --with-libwrap --with-bcrelay
- # Add here commands to compile the package.
- $(MAKE)
- touch build-stamp
- clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp install-stamp
- # Add here commands to clean up after the build process.
- -$(MAKE) distclean
- dh_clean
- install: install-stamp
- install-stamp: build-stamp
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
- # Add here commands to install the package into debian/tmp.
- $(MAKE) install prefix=`pwd`/debian/tmp/usr mandir=`pwd`/debian/tmp/usr/share/man
- cp debian/pptpd.conf `pwd`/debian/tmp/etc
- cp debian/pptpd-options `pwd`/debian/tmp/etc/ppp
- #cp debian/pptpdconfig.pl `pwd`/debian/tmp/usr/sbin
- touch install-stamp
- # Build architecture-independent files here.
- binary-indep: build install
- # We have nothing to do by default.
- # Build architecture-dependent files here.
- binary-arch: build install
- # dh_testversion
- dh_testdir
- dh_testroot
- dh_installdocs
- # mv `pwd`/debian/tmp/usr/share/doc/pptpd/html/*.txt `pwd`/debian/tmp/usr/share/doc/pptpd/
- dh_installexamples
- # dh_installmenu
- # dh_installemacsen
- dh_installinit
- # dh_installcron
- dh_installmanpages
- # dh_installdebconf
- # dh_undocumented
- dh_installchangelogs -k ChangeLog
- dh_strip
- dh_compress
- dh_fixperms
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- # dh_makeshlibs
- dh_md5sums
- dh_builddeb
- source diff:
- @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
- binary: binary-indep binary-arch
- .PHONY: build clean binary-indep binary-arch binary
|