Subject: Fixing warning on python 3.8
Origin: 0.4.15-31-g063a667 <https://github.com/ahupp/python-magic/commit/063a667>
Upstream-Author: Gabriel Diego Teixeira <gabrieldiegoteixeira@gmail.com>
Date: Wed Feb 27 19:33:40 2019 -0800
Bug-Ubuntu: https://bugs.launchpad.net/ubuntu/+source/python-magic/+bug/1857148

--- a/magic/__init__.py
+++ b/magic/__init__.py
@@ -201,7 +201,7 @@
         return result
 
 def errorcheck_negative_one(result, func, args):
-    if result is -1:
+    if result == -1:
         err = magic_error(args[0])
         raise MagicException(err)
     else: