cherry-pick.0.4.11-32-g9d127ce.update-filetype-reported-by-libmagic-5-23-for-keep-going-true.patch 552 B

12345678910111213141516
  1. Subject: Update filetype reported by libmagic >=5.23 for keep_going=true
  2. Origin: 0.4.11-32-g9d127ce
  3. Upstream-Author: Adam Hupp <adam@hupp.org>
  4. Date: Sun Oct 1 20:52:48 2017 -0700
  5. --- a/test/test.py
  6. +++ b/test/test.py
  7. @@ -94,7 +94,7 @@
  8. self.assertEqual(m.from_file(filename), 'image/jpeg')
  9. m = magic.Magic(mime=True, keep_going=True)
  10. - self.assertEqual(m.from_file(filename), 'image/jpeg')
  11. + self.assertEqual(m.from_file(filename), 'image/jpeg\\012- application/octet-stream')
  12. def test_rethrow(self):