2021-01-16.locale-in-tests.patch 976 B

123456789101112131415161718192021222324252627
  1. Subject: Adjust locale check in test suite
  2. Author: Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
  3. Date: 2021-01-16
  4. Forwarded: no
  5. Upstream wishes to run the test suite with LC_ALL set to
  6. en_US.UTF-8 which is not available during build by default.
  7. Instead of adding a build dependeny on locales-all and poking
  8. some environment variables, just change this to C.UTF-8 which
  9. does the trick as well, without additional cost.
  10. --- a/test/test.py
  11. +++ b/test/test.py
  12. @@ -3,10 +3,10 @@
  13. # for output which reports a local time
  14. os.environ['TZ'] = 'GMT'
  15. -if os.environ.get('LC_ALL', '') != 'en_US.UTF-8':
  16. +if os.environ.get('LC_ALL', '') != 'C.UTF-8':
  17. # this ensure we're in a utf-8 default filesystem encoding which is
  18. # necessary for some tests
  19. - raise Exception("must run `export LC_ALL=en_US.UTF-8` before running test suite")
  20. + raise Exception("must run `export LC_ALL=C.UTF-8` before running test suite")
  21. import shutil
  22. import os.path