disable-gzip-test.patch 787 B

123456789101112131415161718
  1. Subject: Disable gzip test, it cannot cope with a recent change in libmagic
  2. Author: Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
  3. Date: 2018-07-21
  4. Bug-Debian: https://bugs.debian.org/897471
  5. Bug-Upstream: https://github.com/ahupp/python-magic/issues/173
  6. --- a/test/test.py
  7. +++ b/test/test.py
  8. @@ -67,9 +67,6 @@
  9. self.assert_values(m, {
  10. 'magic._pyc_': 'python 2.4 byte-compiled',
  11. 'test.pdf': 'PDF document, version 1.2',
  12. - 'test.gz':
  13. - ('gzip compressed data, was "test", from Unix, last modified: Sun Jun 29 01:32:52 2008',
  14. - 'gzip compressed data, was "test", last modified: Sun Jun 29 01:32:52 2008, from Unix'),
  15. 'text.txt': 'ASCII text',
  16. })
  17. finally: