2022-06-05.adjust-tox.patch 478 B

123456789101112131415161718192021222324
  1. Subject: Adjust tox.ini for Debian's python3-coverage
  2. Author: Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
  3. Date: 2022-06-05
  4. Forwarded: not-needed
  5. --- a/tox.ini
  6. +++ b/tox.ini
  7. @@ -12,7 +12,7 @@
  8. [testenv]
  9. commands =
  10. - coverage run -m pytest
  11. + python3-coverage run -m pytest
  12. setenv =
  13. COVERAGE_FILE=.coverage.{envname}
  14. @@ -21,6 +21,7 @@
  15. .[test]
  16. coverage
  17. pytest
  18. +allowlist_externals = python3-coverage
  19. [testenv:coverage-clean]
  20. deps = coverage