Browse Source

Packaging maintenance

* Declare compliance with Policy 4.4.0
* Bump debhelper compat level to 12
* Add Pre-Depends: clause as lintian asks for it
Christoph Biedl 2 years ago
parent
commit
d926f652f4
2 changed files with 4 additions and 3 deletions
  1. 0 1
      debian/compat
  2. 4 2
      debian/control

+ 0 - 1
debian/compat

@@ -1 +0,0 @@
-11

+ 4 - 2
debian/control

@@ -1,16 +1,18 @@
 Source: softflowd
 Maintainer: Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
 Homepage: https://github.com/irino/softflowd
-Standards-Version: 4.2.1
+Standards-Version: 4.4.0
 Vcs-Browser: https://git.in-ulm.de/cbiedl/softflowd
 Vcs-Git: https://git.in-ulm.de/cbiedl/softflowd.git
-Build-Depends: debhelper (>= 11~),
+Build-Depends: debhelper-compat (= 12),
     libpcap0.8-dev,
 Priority: optional
 Section: net
 
 Package: softflowd
 Architecture: any
+Pre-Depends:
+    ${misc:Pre-Depends},
 Depends: ${misc:Depends}, ${shlibs:Depends},
     lsb-base,
     netbase,