cherry-pick.softflowd-0.9.9-9-gb7e50ae.added-support-for-the-pflog-datalink-type-and-fixed-some-typos.patch 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637
  1. Subject: Added support for the pflog datalink type and fixed some typos
  2. Origin: softflowd-0.9.9-9-gb7e50ae <https://github.com/irino/softflowd/commit/softflowd-0.9.9-9-gb7e50ae>
  3. Upstream-Author: SysError956 <paulgodard@gmail.com>
  4. Date: Thu Mar 23 20:36:50 2017 -0400
  5. --- a/softflowd.8
  6. +++ b/softflowd.8
  7. @@ -116,7 +116,7 @@
  8. that the accounting datagrams are to be sent to.
  9. The host may be specified using a hostname or using a numeric IPv4 or
  10. IPv6 address.
  11. -Numeric IPv6 addresses should be encosed in square brackets to avoid ambiguity
  12. +Numeric IPv6 addresses should be enclosed in square brackets to avoid ambiguity
  13. between the address and the port.
  14. The destination port may be a portname listed in
  15. .Xr services 5
  16. --- a/softflowd.c
  17. +++ b/softflowd.c
  18. @@ -90,6 +90,9 @@
  19. #ifdef DLT_LOOP
  20. { DLT_LOOP, 4, 0, 4, 1, 0xffffffff, AF_INET, AF_INET6 },
  21. #endif
  22. +#ifdef DLT_PFLOG
  23. + { DLT_PFLOG, 48, 1, 1, 0, 0x000000ff, AF_INET, AF_INET6 },
  24. +#endif
  25. { -1, -1, -1, -1, -1, 0x00000000, 0xffff, 0xffff },
  26. };
  27. @@ -1297,7 +1300,7 @@
  28. print_timeouts(ft, ctlf);
  29. ret = 0;
  30. } else {
  31. - fprintf(ctlf, "Unknown control commmand \"%s\"\n", buf);
  32. + fprintf(ctlf, "Unknown control command \"%s\"\n", buf);
  33. ret = 0;
  34. }